xt:Commerce Webshop Shop Support

xt:Commerce Webshop Shop Support (http://www.xt-commerce.com/forum/)
-   PHP & MysQL Forum (http://www.xt-commerce.com/forum/php-mysql-forum/)
-   -   Bilder und Content Verlust nach Verzeichnisänderung (http://www.xt-commerce.com/forum/php-mysql-forum/59953-bilder-und-content-verlust-nach-verzeichnis-nderung.html)

nowhereman 18.03.2008 16:56

Bilder und Content Verlust nach Verzeichnisänderung
 
Hallo,

ich hoffe jemand von Euch kann mir helfen.

Ich habe in den letzten Tagen unseren Shop neu mit XT-C erstellt.

Dabei lagen die Daten im Verzeichnis www.tenten-boats.de/shop
Der Shop funktionierte ohne Probleme.

Heute habe ich den XTC-Installer noch einmal laufen lassen und die Shop Verzeichnisse auf dass Hauptverzeichnis also www.tenten-boats.de/ geändert. (Zuvor habe ich jedoch alle Inhalte des Verzeichnisses /shop in das Hauptverzeichnis www.tenten-boats,de/ verschoben.

Zwar wird mein zuvor umgestaltetes Template geladen, aber alle verknüpften Bilder, die Kategorien und die Content Inhalte sin weg. Ich hoffe nicht für immer:confused:

Wie kann ich das eventuell rückgängig bzw. wieder funktioniered machen?

Vielen Dank im Voraus

Gruß Kevin

polkhigh33 18.03.2008 17:07

hast du bei der neuen installation eine neue datenbank verwendet oder die alte geleert und diese wieder verwednet? wenn du zweiteres gemacht hast ist logischerweise alles was bis dahin in der db war jetzt weg.

nowhereman 18.03.2008 19:12

Vielen Dank für die schnelle Antwort,

Eine neue Datenbank habe ich auf keinen Fall verwendet.
Allerdings ist mir auch nicht bewusst, dass ich die alte geleert habe.

Wiederverwendet im XTC-Installer habe ich sie aber schon

Gruß Kevin

John Steed 19.03.2008 14:42

Zitat:

Wiederverwendet im XTC-Installer habe ich sie aber schon
Tja, ätsch. Dann ist alles weg. Okay, die Bilder sind wohl noch da, aber die Datenbank ist leer! :(

Deshalb soll man ja vor *allen* Änderungen an der DB ein Backup machen...

Der Installer legt die Tabellen alle neu an und löscht ("dropt") eventuell schon vorhandene. Hier mal nur als Beispiel die erste Abfrage, die der Installer macht:
Zitat:

DROP TABLE IF EXISTS address_book;
CREATE TABLE address_book (
usw...
Das ist auch in Ordnung so.

Nur um den Pfad zu ändern, hättest Du den Installer auch gar nicht gebraucht - dafür sind nur wenige Änderungen an den configure-Dateien nötig. Anleitungen dazu findest Du hier im Forum über die Suchfunktion zuhauf.

Sorry,

IaN

nowhereman 19.03.2008 18:46

Tja,

das habe ich mir beinahe gedacht.
Dann heist es wohl erst einmal frohe Osterarbeit.

Aber, aus Fehlern lernt man.

Trotzdem vielen Dank für Eure Hlfe

Ede76 26.02.2010 06:40

Ändern der Serveradresse
 
Hallo Leute,

habe zum ersten Mal xtcommerce (Version 3.x) verwendet und der Shop liegt nun fix und fertig in folgendem Verzeichnis: www.meine-domain.de/shop/xtcommerce

Nun möchte ich, dass der Shop unter der Hauptdomain "www.meine-domain.de" aufgerufen wird. Hierzu habe ich bei meinem Provider eine Domainweiterleitung auf das Unterverzeichnis shop/xtcommerce/index.php eingerichtet. Leider zerschießt es mir dadurch das Shoplayout.

Welche Änderungen sind daher in welchen Daten konkret erforderlich, damit das wieder funktioniert?

Danke schon mal für eure Hilfe! :D

Gruß -
Ede

polkhigh33 26.02.2010 09:37

in includes/configure.php und admin/includes/configure.php

Code:

define('DIR_WS_CATALOG', '/shop/xtcommerce/');
ändern in
Code:

define('DIR_WS_CATALOG', '/');

in admin/includes/configure.php zusätzlich noch

Code:

define('DIR_WS_ADMIN', '/shop/xtcommerce/admin/');
ändern in
Code:

define('DIR_WS_ADMIN', '/admin/');
das wars.

bei der weiterleitung kannst du das index.php auch weglassen.

Ede76 26.02.2010 09:49

Danke für die schnelle Antwort. Werd ich heute Nachmittag gleich probieren.

Wenn das funktioniert, stell ich vor lauter Freude nen Kirwabaum im Garten auf! :)

Ede76 03.03.2010 16:21

Upload funzt nicht
 
Upload geht nicht. Hm...liegt es an den Rechten?

-------
UPDATE:
Hat jetzt funktioniert, hatte jedoch kurzzeitig Probleme mit dem Upload der Dateien über FTP.
Ging erst, als ich die Originaldateien vom Server gelöscht habe. Dann hab ich die überarbeiteten PHP-Dateien hochgeladen und die Rechte auf "444" gesetzt. War das so korrekt?

Ich habe im übrigen auch noch die beiden "configure.org.php" bei includes und admin/includes anpassen müssen. Sonst ging es nicht.

Jetzt kann ich nur hoffen, dass keine Fehlermeldungen kommen. Mein erster Onlineshop - ijöööööööh - ich mach mir jetzt ein Bierchen auf! :-)

Danke für deine Hilfe!!!!!!


Alle Zeitangaben in WEZ +1. Es ist jetzt 13:20 Uhr.

Powered by vBulletin® Version 3.8.7 (Deutsch)
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright xt:Commerce GmbH


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54